menu

Apollo

A community of developers, designers and others who love Apollo and GraphQL. 🚀

Channels
# All channels
view-forward
# General
view-forward
# Apollo Angular
view-forward
# Announcements
view-forward
# Apollo Android
view-forward
# Apollo Client
view-forward
# Apollo iOS
view-forward
# Apollo Link
view-forward
# Apollo Link Rest
view-forward
# Local State
view-forward
# Apollo Studio
view-forward
# Apollo Server
view-forward
# Apollo Tooling
view-forward
# Contributing
view-forward
# Docs
view-forward
# Events
view-forward
# GraphQL Tools
view-forward
# Jobs
view-forward
# Random
view-forward
# React Apollo
view-forward
# Showcase
view-forward
# Subscriptions
view-forward
# Testing
view-forward
# Vue Apollo
view-forward
Team

Compatible with Angular 9?

June 23, 2020 at 3:01pm

Compatible with Angular 9?

June 23, 2020 at 3:01pm (Edited 3 months ago)
I'm trying to use Apollo-Angular with angular 9, but i get the following error:
ERROR in node_modules/apollo-angular-link-http/HttpLinkModule.d.ts:3:22 - error NG6003: Appears in the NgModule.exports of GraphQLModule, but could not be resolved to an NgModule, Component, Directive, or Pipe class.
This likely means that the library (apollo-angular-link-http) which declares HttpLinkModule has not been processed correctly by ngcc, or is not compatible with Angular Ivy. Check if a newer version of the library is available, and update if so. Also consider checking with the library's authors to see if the library is expected to be compatible with Ivy.
export declare class HttpLinkModule {
~~~~~~~~~~~~~~
src/app/graphql.module.ts:24:14 - error NG6002: Appears in the NgModule.imports of AppModule, but itself has errors
export class GraphQLModule {}
Is this a know error or am i doing something wrong?

June 23, 2020 at 3:10pm
It seems to be something specific with my project, if i just create a new project and add apollo-angular i don't get any errors.
  • reply
  • like