menu

Apollo

A community of developers, designers and others who love Apollo and GraphQL. 🚀

Channels
# All channels
view-forward
# General
view-forward
# Apollo Angular
view-forward
# Announcements
view-forward
# Apollo Android
view-forward
# Apollo Client
view-forward
# Apollo iOS
view-forward
# Apollo Link
view-forward
# Apollo Link Rest
view-forward
# Local State
view-forward
# Apollo Studio
view-forward
# Apollo Server
view-forward
# Apollo Tooling
view-forward
# Contributing
view-forward
# Docs
view-forward
# Events
view-forward
# GraphQL Tools
view-forward
# Jobs
view-forward
# Random
view-forward
# React Apollo
view-forward
# Showcase
view-forward
# Subscriptions
view-forward
# Testing
view-forward
# Vue Apollo
view-forward
Team

Protocol problem using WebsocketLink

July 28, 2020 at 2:45pm

Protocol problem using WebsocketLink

July 28, 2020 at 2:45pm
Hi! On the past few weeks i was trying to connect my React apllication using an Elixir Server, and while i was trying to connect on Firefox everything works fine, but on Chrome i get this error: Error during WebSocket handshake: Sent non-empty 'Sec-WebSocket-Protocol' header but no response was received
I realized that the problem was the Sec-WebSocket-Protocol, having the following value: graphql-ws
So, how can i set the protocol as empty on WebsocketLink? This is my config right now
q.png

September 23, 2020 at 2:02pm
Hey Daniel, do u still need help here?
  • reply
  • like

November 30, 2020 at 9:03am
Hey (daniel-jose-padilha) (martinnirtl) , any idea how solve this? Having this issue right now, still figuring out the solution.
  • reply
  • like