menu

Apollo

A community of developers, designers and others who love Apollo and GraphQL. 🚀

Channels
# All channels
view-forward
# General
view-forward
# Apollo Angular
view-forward
# Announcements
view-forward
# Apollo Android
view-forward
# Apollo Client
view-forward
# Apollo iOS
view-forward
# Apollo Link
view-forward
# Apollo Link Rest
view-forward
# Local State
view-forward
# Apollo Studio
view-forward
# Apollo Server
view-forward
# Apollo Tooling
view-forward
# Contributing
view-forward
# Docs
view-forward
# Events
view-forward
# GraphQL Tools
view-forward
# Jobs
view-forward
# Random
view-forward
# React Apollo
view-forward
# Showcase
view-forward
# Subscriptions
view-forward
# Testing
view-forward
# Vue Apollo
view-forward
Team

Poor graphql playground

June 5, 2020 at 8:21pm

Poor graphql playground

June 5, 2020 at 8:21pm (Edited 4 months ago)
Hey, I am using: apollo-server: 2.14.2, apollo-server-express: ^2.14.2 and the graphql playground it comes with seems to be broken, e.g scrolling responses from subscription queries don't work. I would like to see responses in top vs showing up in bottom (to which I can't scroll).
Playground version that it comes with is 1.7.32. I could change version by passing it apollo server but that seams to be the latest one.
const server = new ApolloServer({ schema, playground: { version: ‘1.7.20’ } })
Should I use standalone graphql playground or I am missing sth?

June 5, 2020 at 9:47pm
This was fixed recently in GraphQL Playground. But... Apollo Server uses a poorly-maintained fork of Playground which won't include the changes. You can't use yarn dependency resolution either because it's a fork. But there is a workaround: https://twitter.com/ReardenQL/status/1266063748013441025
  • reply
  • like
thanks Daniel, it works!
  • reply
  • like