menu

Apollo

A community of developers, designers and others who love Apollo and GraphQL. 🚀

Channels
Team

Contribute Apollo Server in Windows

December 31, 2019 at 3:19pm

Contribute Apollo Server in Windows

December 31, 2019 at 3:19pm (Edited 9 months ago)
Hi, i want to contribute in the Apollo Server project, but the package apollo-engine-reporting-protobuf building process apparently is incompatible with windows OS.
All i get trying to install the dependencies is
lerna notice cli v3.20.1
lerna info versioning independent
lerna info Executing command in 2 packages: "npm run prepare"
lerna ERR! npm run prepare exited 1 in 'apollo-engine-reporting-protobuf'
lerna ERR! npm run prepare stdout:
> [email protected] prepare C:\Users\pablo\Documents\apollo-server\packages\apollo-engine-reporting-protobuf
> npm run pbjs && npm run pbts
> [email protected] pbjs C:\Users\pablo\Documents\apollo-server\packages\apollo-engine-reporting-protobuf
> bash -c 'mkdir -p dist && apollo-pbjs --target static-module --out dist/protobuf.js --wrap commonjs --force-number <(grep -v "package mdg.engine.proto" src/reports.proto)'
lerna ERR! npm run prepare stderr:
The system cannot find the file specified.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] pbjs: `bash -c 'mkdir -p dist && apollo-pbjs --target static-module --out dist/protobuf.js --wrap commonjs --force-number <(grep -v "package mdg.engine.proto" src/reports.proto)'`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] pbjs script.
Is it possible to improve it's building process to be cross platform compatible?

December 31, 2019 at 4:23pm
UPDATE: Not even in Linux Subsystem works, at this point I don't know if it's a deeper problem within the repository
  • reply
  • like