menu

Aragon

Aragon is the most powerful and modular way to run DAOs

Channels
# All channels
view-forward
# Announcements
view-forward
# App development
view-forward
# Aragon Agent
view-forward
# Aragon Client
view-forward
# Aragon Connect
view-forward
# aragonOS
view-forward
# aragonUI
view-forward
# Feature requests
view-forward
Team

Problem trying to install aragon app on a rinkeby dao

May 3, 2020 at 3:46pm

Problem trying to install aragon app on a rinkeby dao

May 3, 2020 at 3:46pm (Edited 2 months ago)
I'm trying to install a published app (task-allocation) on a dao running a IPFS daemon separately and using the following command:
dao install 0x81cE3A48cfdB4E0E35bb0454E2b1E9a337E10247 task-allocation.open.aragonpm.eth --environment aragon:rinkeby
I get the following error:
❯ Fetching [email protected]
✖ Get Repo
→ Cannot find artifacts in aragonPM repo. Please make sure the package is
Checking installed version
Deploying app instance
Fetching deployed app
✖ Cannot find artifacts in aragonPM repo. Please make sure the package is published and IPFS or your HTTP server running.
If you check my app versions on apm you can see it was published successfully:
aragon apm versions task-allocation.open.aragonpm.eth --environment aragon:rinkeby
✔ Fetching task-allocation.open.aragonpm.eth published versions
ℹ task-allocation.open.aragonpm.eth has 2 published versions
✔ 1.0.0: 0x2235D1c1FC05D0b85e5323734F115FfFe39Db792 ipfs:QmZLqCgGkL23fx7MP5d4ZEQjzUBEupKY9zNNH75yqwXS5w
✔ 1.1.0: 0x2235D1c1FC05D0b85e5323734F115FfFe39Db792 ipfs:QmRqYbKgfd3J2wssSF87QQ27WuQfpjnYpo2kUvqf5TQSU6
I have no problems installing other apps from the same repository, what could be the issue ?
Thanks!

May 4, 2020 at 4:38am
Thanks for reporting this issue. I can indeed replicate the problem, though not exactly with the same error. I will investigate this.
  • reply
  • like

May 4, 2020 at 3:36pm
Thanks!. I don't know if it helps but I use the aragon buidler to publish every app version (npx buidler publish <bump> --network rinkeby). Maybe it's still experimental and didn't do it right
Edited
  • reply
  • like
The files on IPFS look pretty good so far, maybe it was just the propagation of the IPFS files to our gateway. I'm assuming the issue still stands?
  • reply
  • like

May 22, 2020 at 11:08am
Hi, sorry for my late reply. Yes, I was having problems propagating the app's artifact.json and manifest.json files
Edited
  • reply
  • like