menu

CameraKit

One of the hardest Android APIs made into a high level and easy to use library that solves all of your problems.

Channels
Team

Will the 1.0.0 API be backward compatible with 0.13.x?

January 31, 2019 at 11:07pm

Will the 1.0.0 API be backward compatible with 0.13.x?

January 31, 2019 at 11:07pm

Couldn't find an answer to this on the Github page or in the documentation


February 6, 2019 at 8:58pm

Hey Sean, thanks for the question. 1.0.0 will not be directly backwards compatible with 0.13.x. Some of the methods have changed their implementation as we've refactored the library.

When we roll out 1.0.0 proper, we will include documentation for those migrating from 0.13.x!

  • reply
  • like

February 9, 2019 at 7:44am

@emerson-cloud could you specify then cameraKit 1.0.0 would hit stable? :) Right now we use Fotoapparat library, but we are planning for switching, We have built an SDK which requires good camera support, so right now we can't use beta version for that matter, because clients are unwilling for using beta versions...

  • reply
  • like