Join the conversation

Sign in to join this conversation, and others like it, in the communities you care about.

CameraKit

One of the hardest Android APIs made into a high level and easy to use library that solves all of your problems.

CameraKit / General

What is the min API support?

What is the min API support?

CameraKit / General · November 1, 2018 at 9:25pm
What is the min api support for lastest CamerKit library. I'm receiving the following crash on API 16 and 17 devices,
android.support.v4.app.FragmentManagerImpl.removeRedundantOperationsAndExecute(FragmentManager.java:2338) 
at android.support.v4.app.FragmentManagerImpl.execSingleAction(FragmentManager.java:2215) 
at android.support.v4.app.BackStackRecord.commitNowAllowingStateLoss(BackStackRecord.java:649) 
at android.support.v4.app.FragmentStatePagerAdapter.finishUpdate(FragmentStatePagerAdapter.java:167) 
at android.support.v4.view.ViewPager.populate(ViewPager.java:1238) 
at android.support.v4.view.ViewPager.populate(ViewPager.java:1086) 
at android.support.v4.view.ViewPager.setAdapter(ViewPager.java:534) 
at com.textmeinc.textme3.chat.view.ChatFragment.loadAttachmentContainer(ChatFragment.kt:2988) 
at com.textmeinc.textme3.chat.view.ChatFragment.setupAttachment(ChatFragment.kt:438) 
at com.textmeinc.textme3.chat.view.ChatFragment.access$setupAttachment(ChatFragment.kt:152) 
at com.textmeinc.textme3.chat.view.ChatFragment$setComposer$3.onClick(ChatFragment.kt:2917) 
at android.view.View.performClick(View.java:4204) 
at android.view.View$PerformClick.run(View.java:17355) 
at android.os.Handler.handleCallback(Handler.java:725) 
at android.os.Handler.dispatchMessage(Handler.java:92) 
at android.os.Looper.loop(Looper.java:137) 
at android.app.ActivityThread.main(ActivityThread.java:5041) 
at java.lang.reflect.Method.invokeNative(Native Method) 
at java.lang.reflect.Method.invoke(Method.java:511) 
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793) 
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560) 
at dalvik.system.NativeStart.main(Native Method) 
Caused by: java.lang.UnsatisfiedLinkError: Cannot load library: soinfo_link_image(linker.cpp:1635): could not load library "libcamerakit-core.so" needed by "libcamerakit.so"; caused by load_library(linker.cpp:745): library "libcamerakit-core.so" not found
at java.lang.Runtime.loadLibrary(Runtime.java:371)
at java.lang.System.loadLibrary(System.java:535)
at com.camerakit.preview.CameraSurfaceView.<clinit>(CameraSurfaceView.kt:109)
at com.camerakit.CameraPreview.<init>(CameraPreview.kt:78) 
at com.camerakit.CameraKitView.obtainAttributes(CameraKitView.java:268) 
at com.camerakit.CameraKitView.<init>(CameraKitView.java:237) 
at java.lang.reflect.Constructor.constructNative(Native Method) 
at java.lang.reflect.Constructor.newInstance(Constructor.java:417) 
at android.view.LayoutInflater.createView(LayoutInflater.java:587) 
at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:687) 
at android.view.LayoutInflater.rInflate(LayoutInflater.java:746) 
at android.view.LayoutInflater.inflate(LayoutInflater.java:489) 
at android.view.LayoutInflater.inflate(LayoutInflater.java:396) 
at android.databinding.DataBindingUtil.inflate(DataBindingUtil.java:126) 
at com.textmeinc.textme3.databinding.FragmentCameraBinding.inflate(FragmentCameraBinding.java:74) 
at com.textmeinc.textme3.databinding.FragmentCameraBinding.inflate(FragmentCameraBinding.java:68) 
at com.textmeinc.textme3.fragment.attachment.CameraFragment.onCreateView(CameraFragment.kt:69) 
at android.support.v4.app.Fragment.performCreateView(Fragment.java:2346) 
at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1428) 
at android.support.v4.app.FragmentManagerImpl.moveFragmentToExpectedState(FragmentManager.java:1759) 
at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1827) 
at android.support.v4.app.BackStackRecord.executeOps(BackStackRecord.java:797) 
at android.support.v4.app.FragmentManagerImpl.executeOps(FragmentManager.java:2596) 
at android.support.v4.app.FragmentManagerImpl.executeOpsTogether(FragmentManager.java:2383) 

November 13, 2018 at 3:15pm

Our min API version is 15!

  • reply
  • like
Your message here...

*bold*_italic_`code````codeblock```