menu

CameraKit

One of the hardest Android APIs made into a high level and easy to use library that solves all of your problems.

Channels
Team
Posts
Members
Info

Signal 11 ( SIGSEGV ) crash

I don't actually know if this is CameraKit related but it is the only third-party library I'm using ( and the only part of my app that goes out of the Java/Kotlin layer into C++ ) but I'm seeing a few crashes from the App Store that look like this: signal 11 (SIGSEGV), code 1…

thumbsup
0
message-simple
0

Has anyone implemented QR Scanning with CameraKit?

thumbsup
0
message-simple
0
Adarsh·21d

How to add Preview

Hi, I am looking for some help to create a preview after an image is clicked. Currently, the image is saving to the filesystem. My app has 1 main activity currently with a camerakitview and a button. Once I click the image, I want it to open the preview of the image followed by…

thumbsup
0
message-simple
1
Dil3mm4·22d

Hello

Just kicking-in to salute you all! :)

thumbsup
0
message-simple
0

Variable FORCE_DEPRECATED_API will be accessible in the v1 ?

Hi, in some device (like Samsung XCover), the Camera2 API don't work well. But the phone is on API level 27, so CameraKit use Camera2. Have you plan to put the "FORCE_DEPRECATED_API" boolean accessible outside of the library ? I have seen that that boolean force the Camera1…

thumbsup
0
message-simple
0

Front Flash in Camerakit

Is there any code to enable front flash ?

thumbsup
0
message-simple
1
Tsabary·43d

Is there any documentation for using CameraKit with Kotlin?

I am currently having unconsistancy issues with capturing https://stackoverflow.com/questions/55526362/capture-image-action-only-works-sometimes-without-clear-reason-why And I wonder if I'm doing something wrong. I can't find any guides on how to use the library with Kotlin.

thumbsup
0
message-simple
6

Torch supported?

Using getSupportedFlashTypes() returns NULL....is that normal? I set the flash to FLASH_TORCH....when I check it using getFlash() it shows it is set to 3. However, my torch is not on. What am I doing wrong? Snippet below. I'm using 1.0.0-beta3.11 CameraFlash[] cameraFlashes =…

thumbsup
0
message-simple
0

Checking in on video for the 1.0.0 beta series

Hey - I'm just checking in to see if there has been any progress recently on support for video in the 1.0.0 cuts? If not, is there anything we can do as a community to help with it? Thanks for all your work - the library is superb!

thumbsup
2
message-simple
1

I don't understand, `master` branch is v0.13.5 but the demo app (in the same…

Why?

thumbsup
0
message-simple
1