menu
Channels
Team

Hey all - WSL2 yarn start very slow

November 13, 2019 at 7:58pm

Hey all - WSL2 yarn start very slow

November 13, 2019 at 7:58pm (Edited 29 days ago)
Not sure if anyone has experience using create-react-app in WSL2, but my yarn start command is running awfully slow. Does anyone have any suggestions that may help? I've gone ahead and created another test app and found similar results. My computer specs: intel i7-8650U 2.11 GHz, 16GB RAM Windows 10 Pro [Version 10.0.19018.1], Distro: Ubuntu 18.04.3
Here is a timestamp:
yarn start | gnomon 0.1479s yarn run v1.19.1 62.9449s $ react-scripts start 0.0002s Starting the development server... 72.7701s 0.0001s Compiled successfully! 0.0001s 0.0001s You can now view monster-rolodex in the browser. 0.0001s 0.0001s Local: http://localhost:3000/ 0.0001s On Your Network: http://xxx.xxx.xx.xxx:3000/ 0.0001s 54.6532s
Any help would be great!

November 15, 2019 at 7:56am
Have you verified that you're really using WSL2? https://docs.microsoft.com/en-us/windows/wsl/wsl2-install
I don't usually work with WSL, but have used v1 in the past on a modern laptop similar to yours, with an SSD. BTW, whether you have an SSD or not is the most crucial detail, which you omitted :). Anyway, while it was noticeably slower than Linux, it was usable for real world projects. I haven't tried WSL2 yet though.
Edited
  • reply
  • like

November 15, 2019 at 11:35pm
Hey Nick, sorry I forgot to mention but yes I do in fact have an SSD! and verified that i was running on WSL2. The issue persisted so I just reverted back to WSL v1 and that solved my issue.
  • reply
  • like
Good to know that it still is buggy - especially specifically where an improvement is to be expected. 😅 Consider filing a bug: https://github.com/microsoft/wsl/issues
  • reply
  • like

November 18, 2019 at 4:49pm
This shouldn't happen... I'm sad that WSL2 is still not quite there, but I'm excited about it. I want to get a new Surface to replace this Mac.
  • reply
  • like
then why wait? Try Linux.
  • reply
  • like

November 19, 2019 at 9:00am
I've tried, I need certain apps and I feel it's more polished. I also like to game, do work in Photoshop, etc.
  • reply
  • like
i would give it a try, it could be my environment. Maybe I did something wrong. Theres just a lot of variables. I'm going to try uninstalling and reinstalling WSL versions 1 and 2 and see if that helps my issue this weekend.
  • reply
  • like