menu
announcement

Spectrum is now read-only. Learn more about the decision in our official announcement.

Divjoy

The ⚛️ React codebase generator.

Channels
Team

vercel deployment error

December 17, 2020 at 10:59am

vercel deployment error

December 17, 2020 at 10:59am
I use vercel dev is working. but same warnings. Compiled with warnings.
src/components/NavbarCustom.js Line 11:9: 'auth' is assigned a value but never used no-unused-vars Line 12:9: 'router' is assigned a value but never used no-unused-vars
src/pages/auth0-callback.js Line 1:8: 'React' is defined but never used no-unused-vars
src/util/contact.js When I use vercel dev same warning. " Compiled with warnings.
src/components/NavbarCustom.js Line 11:9: 'auth' is assigned a value but never used no-unused-vars Line 12:9: 'router' is assigned a value but never used no-unused-vars
src/pages/auth0-callback.js Line 1:8: 'React' is defined but never used no-unused-vars
src/util/contact.js Line 13:1: Assign object to a variable before exporting as module default import/no-anonymous-default-export
src/util/newsletter.js Line 7:1: Assign object to a variable before exporting as module default import/no-anonymous-default-export
Search for the keywords to learn more about each warning. To ignore, add // eslint-disable-next-line to the line before. " i want to use vercel for vercel deployment. vercel deploy error.
Command "npm run build" exited with 1
2020-12-17T10:14:33.036Z Uploading build outputs... 2020-12-17T10:14:34.287Z Done with "api/newsletter.js" 2020-12-17T10:14:34.949Z Installing build runtime... 2020-12-17T10:14:34.953Z yarn info /[email protected] 2020-12-17T10:14:34.958Z yarn info /node... 2020-12-17T10:14:35.529Z Build runtime installed: 579.861ms 2020-12-17T10:14:36.163Z Running api/items-get.js builder.exports.build... 2020-12-17T10:14:36.165Z Installing dependencies... 2020-12-17T10:14:39.836Z npm WARN [email protected] requires a peer of [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself. 2020-12-17T10:14:39.844Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/chokidar/node_modules/fsevents): 2020-12-17T10:14:39.844Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:39.852Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 2020-12-17T10:14:39.852Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:39.858Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/watchpack-chokidar2/node_modules/fsevents): 2020-12-17T10:14:39.858Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:39.866Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/webpack-dev-server/node_modules/fsevents): 2020-12-17T10:14:39.866Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:39.866Z 2020-12-17T10:14:39.867Z up to date in 8.955s 2020-12-17T10:14:40.732Z 2020-12-17T10:14:40.733Z 128 packages are looking for funding 2020-12-17T10:14:40.733Z run npm fund for details 2020-12-17T10:14:40.733Z 2020-12-17T10:14:45.171Z Uploading build outputs... 2020-12-17T10:14:46.272Z Done with "api/user-update.js" 2020-12-17T10:14:50.145Z npm WARN [email protected] requires a peer of [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself. 2020-12-17T10:14:50.153Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/chokidar/node_modules/fsevents): 2020-12-17T10:14:50.153Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:50.159Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/watchpack-chokidar2/node_modules/fsevents): 2020-12-17T10:14:50.159Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:50.167Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 2020-12-17T10:14:50.167Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:50.173Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/webpack-dev-server/node_modules/fsevents): 2020-12-17T10:14:50.173Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:14:50.173Z 2020-12-17T10:14:50.173Z up to date in 8.963s 2020-12-17T10:14:51.059Z 2020-12-17T10:14:51.059Z 128 packages are looking for funding 2020-12-17T10:14:51.059Z run npm fund for details 2020-12-17T10:14:51.059Z 2020-12-17T10:14:55.750Z Uploading build outputs... 2020-12-17T10:14:56.914Z Done with "api/user-get.js" 2020-12-17T10:15:00.714Z npm WARN [email protected] requires a peer of [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself. 2020-12-17T10:15:00.723Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/chokidar/node_modules/fsevents): 2020-12-17T10:15:00.723Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:00.730Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 2020-12-17T10:15:00.730Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:00.738Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/watchpack-chokidar2/node_modules/fsevents): 2020-12-17T10:15:00.738Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:00.745Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/webpack-dev-server/node_modules/fsevents): 2020-12-17T10:15:00.745Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:00.746Z 2020-12-17T10:15:00.747Z up to date in 9.163s 2020-12-17T10:15:01.623Z 2020-12-17T10:15:01.623Z 128 packages are looking for funding 2020-12-17T10:15:01.624Z run npm fund for details 2020-12-17T10:15:01.624Z 2020-12-17T10:15:02.144Z Uploading build outputs... 2020-12-17T10:15:03.099Z Done with "api/items-get.js" 2020-12-17T10:15:10.143Z npm WARN [email protected] requires a peer of [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself. 2020-12-17T10:15:10.144Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/chokidar/node_modules/fsevents): 2020-12-17T10:15:10.144Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:10.144Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 2020-12-17T10:15:10.144Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:10.149Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/watchpack-chokidar2/node_modules/fsevents): 2020-12-17T10:15:10.149Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:10.155Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/webpack-dev-server/node_modules/fsevents): 2020-12-17T10:15:10.155Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:10.155Z 2020-12-17T10:15:10.156Z up to date in 8.091s 2020-12-17T10:15:11.024Z 2020-12-17T10:15:11.024Z 128 packages are looking for funding 2020-12-17T10:15:11.025Z run npm fund for details 2020-12-17T10:15:11.025Z 2020-12-17T10:15:15.445Z Uploading build outputs... 2020-12-17T10:15:16.634Z Done with "api/auth-user.js" 2020-12-17T10:15:20.472Z npm WARN [email protected] requires a peer of [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself. 2020-12-17T10:15:20.481Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/chokidar/node_modules/fsevents): 2020-12-17T10:15:20.481Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:20.489Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 2020-12-17T10:15:20.489Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:20.495Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/watchpack-chokidar2/node_modules/fsevents): 2020-12-17T10:15:20.495Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2020-12-17T10:15:20.501Z npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/webpack-dev-server/node_modules/fsevents): 2020-12-17T10:15:20.501Z npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64 2020-12-17T10:15:20.502Z up to date in 9.013s 2020-12-17T10:15:21.345Z 2020-12-17T10:15:21.345Z 128 packages are looking for funding 2020-12-17T10:15:21.345Z run npm fund for details 2020-12-17T10:15:21.345Z 2020-12-17T10:15:24.973Z Uploading build outputs... 2020-12-17T10:15:26.057Z Done with "api/item-update.js" 2020-12-17T10:15:27.810Z Build completed. Populating build cache... 2020-12-17T10:15:29.305Z Running api/user-create.js builder.exports.prepareCache... 2020-12-17T10:15:42.747Z Uploading build cache [30.54 MB]... 2020-12-17T10:15:44.349Z Build cache uploaded: 1601.506ms 2020-12-17T10:15:44.365Z Done with "api/user-create.js" 2020-12-17T10:15:44.710Z Done with "package.json"

December 17, 2020 at 5:11pm
(mtokyay) Thanks for letting me know! These warnings are due to your eslint rules. It looks like these may be the default rules that come with Create React App so I'll make sure to resolve these issues for future exports. They should be fairly easy to resolve by hand and by looking up the errors, but let me know if you need help.