menu
Channels
Team
Posts
Members
Info

cannot commit to own github repo after clone

I followed the step to build erb: git clone --depth 1 --single-branch https://github.com/electron-react-boilerplate/electron-react-boilerplate.git your-project-name cd your-project-name yarn …

thumbsup
0
message-simple
1

How do I add PouchDB to my app?

I have PouchDB installed as a native dependency and everything works in each environment except for when the application in packaged. What do I need to do so that PouchDB is properly packaged with the app. I am using PouchDB in the Node setting, not the browser.

thumbsup
0
message-simple
0
·22d·Locked# General

cannot add puppeteer-core as a dependency

Tried adding to root package.json with yarn add puppeteer-core. Console output below: ❯ yarn add puppeteer-core 11:26:01 …

thumbsup
0
message-simple
2

Created a Component, updated Routes, but Component is not displayed.

Hi, I just cloned this boilerplate and went ahead and created a component. Updated Routes.tsx, routes.json, etc. However, when I click on my app on the new Link, nothing happens. When I check the console I can see the messages from Redux and the payload is showing the navigation…

thumbsup
0
message-simple
6

Debuging in VsCode

Hi, how I can debug the main process and the renderer process in VScode?

thumbsup
0
message-simple
0

VS Code launch.json

I am pretty new to Electron and React and I'd like to get a setup for debugging in VS code. Need to add stuff to launch.json to do that. So far this is what I have but it's not working. { "version": "0.2.0", …

thumbsup
0
message-simple
2

No electron window opens on Windows 10 on `yarn dev`

I might be missing something, but I've tried many of the commands in package.json, but none of them open the electron window in dev. For example, if I run yarn dev it'll startup the dev server, but no electron window shows up. However, if I run npm run package it does create a…

thumbsup
1
message-simple
8

How to use Font Awesome Icons properly?

I'm building a simple SPA with this boilerplate. I got a sidebar for navigate trough my app and I'm using Font Awesome Icons React library for it icons. The icons works fine in dev mode, put when run in production, they just doesn't show up. This is the file I'm using to load…

thumbsup
0
message-simple
6

Building DLLs takes a long time and fails after about 40 minutes

I am not quite sure how this part of the config works , but from what I could tell you are building some kind of linkage between libraries to improve next builds, so I assume some of my depdencies on package.json is causing the issue? It just I am kinda stuck with my…

thumbsup
1
message-simple
4

how do I do an update?

thumbsup
0
message-simple
1