menu

Elide

Elide is a java library built to make it easy to expose JPA beans as either a JSON API or a GraphQL webservice

Channels
Team
Posts
Members
Info

Elide 5 Official Release

Elide 5 is officially released (Version 5.0.1). Full details of changes from Elide 4 can be found here. Changes from the prior release can be found here.

thumbsup
1
message-simple
0

@Inheritance

Im trying to get @Inheritance to work so that I can separate my standard JPA models from the elide annotations. I have the following example First the models ( A site belongs to a time zone) And then the Elide classes extends as follows …

thumbsup
0
message-simple
8

How to enable Links with custom controller implementation

Hello everyone ... We have requirement to use custom controller and have below configuration elide.json-api.enabled=false elide.json-api.enableLinks=true …

thumbsup
0
message-simple
4

elide-spring-boot-starter problem

Build project with elide-spring-boot-starter - 5.0.0-pr32 I use elide-spring-boot-example project like example for my project. https://github.com/Goganesh/jsonApi-java-example/tree/master/education …

thumbsup
0
message-simple
13

Yahoo Hack Together Hackathon

Yahoo is hosting an open source hackathon. Elide is one of the projects. Check out https://yahoo.github.io/hacktogether/ for more details.

thumbsup
3
message-simple
16

elide-spring-boot-starter

The "elide-spring-boot-starter"(Jetty) will cause problem when I run my spring boot application on Tomcat(We need run app on tomcat). Is there any way to create a tomcat version of "elide-spring-boot-starter". Thanks!

thumbsup
0
message-simple
5

Elide 4.7.0 Released

https://github.com/yahoo/elide/blob/elide-4.x/changelog.md#470

thumbsup
0
message-simple
0

Query parameters in JSON Patch extension requests

Hi, we have enabled the JSON Patch extension but have run into an issue with the query parameters. For the regular post/patch/delete requests we sometimes pass information to the DatastoreTransaction in the query parameters, but for the patch extension, Elide does not pass…

thumbsup
0
message-simple
8

Elide 4.6.10 and 5.0.0-pr30 released

See https://github.com/yahoo/elide/discussions/1784 and https://github.com/yahoo/elide/discussions/1786

thumbsup
1
message-simple
0