menu
announcement

Spectrum will become read-only on August 10, 2021. Learn more about the decision in our official announcement.

Framer

The best prototyping tool for teams. Join our Discord chat for weekly classes and real-time help with Framer. http://framer.com/r/discord?utm=spectrum

Channels
Team

Images don't show up in HTML exports

April 17, 2020 at 8:02am

Images don't show up in HTML exports

April 17, 2020 at 8:02am
I have issues exporting images in a web html export in Framer X and Framer X Beta macOS apps. The images are exported and present in source code, but they are never loaded by the browser. An error show up in the console:
Using default assetResolver from runtime. Override by providing an assetResolver to initializeRuntime()
Do you have any idea what it might come from?
It happens with Framer Beta for macOS. Image URL show up in the source code: https://jngl.pm/4guyzr54
Thanks!

April 17, 2020 at 9:26am
Hi Louis! Thanks for bringing this up -- it's a known issue and we're working on a solution as we speak! I hope this isn't blocking your right at this minute too much. I can keep you in the loop once we publish an update to the beta with a fix.
  • reply
  • like
Hi Viktor, is there a workaround that I can use in the meantime? Thank you so much!
  • reply
  • like
I'm afraid the only workaround for now would be to share your project with me so I can export it on our end in our development environment. We can also consider uploading the project to Framer Web and using the Shared Preview we introduced there. This would create a hosted version of your prototype you can then share with others. This will be a website/link though, and not a folder with all the assets.
  • reply
  • like
Thanks Viktor, I'm trying with Framer Web!
Edited
  • reply
  • like

October 1, 2020 at 8:17am
Any update on this? We're having the same issue over here. Seemingly random assets end up missing.
  • reply
  • like

October 6, 2020 at 7:11pm

📣 This community is no longer actively monitored, in favor of Discord

thumbsup
3
message-simple
0
  • reply
  • like

February 26, 2021 at 2:44pm
Is this issue solved in a more recent framer version?
  • reply
  • like
On Framer 2020.49.5 the issue is unresolved.
  • reply
  • like