menu
announcement

Spectrum is now read-only. Learn more about the decision in our official announcement.

Gatsby

Fast in every way that matters. Gatsby is a free and open source framework based on React that helps developers build blazing fast websites and apps.

Channels
Team

Gatsby - Bulma error after updating to Gatsby 3

March 24, 2021 at 11:51am

Gatsby - Bulma error after updating to Gatsby 3

March 24, 2021 at 11:51am
Hi all, long time reader (troubleshooter) first time poster... I have just updated my site from Gatsby 2 to 3 - Everything seems to be going ok so far but I have run in to an error with Bulma.
I can successfully run 'gatsby develop' when removing the bulma line. Has anyone encountered this ? Would love to get some direction on troubleshooting this one.
Thanks Dan
failed Building development bundle - 11.978s ERROR in ./src/components/allstyles.scss Module build failed (from ./nodemodules/mini-css-extract-plugin/dist/loader.js): ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js): SassError: Can't find stylesheet to import. ╷ 15 │ "~bulma/bulma.sass"; │ ^^^^^^^^^^^^^^^^^^^ ╵ src/components/allstyles.scss 15:9 root stylesheet at processResult (/home/danp/DanPDev/dan-p-com-au-website/node_modules/webpack/lib/NormalModule.js:674:19) at /home/danp/DanPDev/dan-p-com-au-website/node_modules/webpack/lib/NormalModule.js:773:5 at /home/danp/DanPDev/dan-p-com-au-website/node_modules/loader-runner/lib/LoaderRunner.js:399:11 at /home/danp/DanPDev/dan-p-com-au-website/node_modules/loader-runner/lib/LoaderRunner.js:251:18 at context.callback (/home/danp/DanPDev/dan-p-com-au-website/node_modules/loader-runner/lib/LoaderRunner.js:124:13) at /home/danp/DanPDev/dan-p-com-au-website/node_modules/sass-loader/dist/index.js:62:7 at Function.call$2 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:91729:16) at _render_closure1.call$2 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:80373:12) at _RootZone.runBinary$3$3 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:27269:18) at _FutureListener.handleError$1 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:25797:19) at _FuturepropagateToListeners_handleError.call$0 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:26094:49) at Object._FuturepropagateToListeners (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:4543:77) at _Future._completeError$2 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:25927:9) at _AsyncAwaitCompleter.completeError$2 (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:25270:12) at Object._asyncRethrow (/home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:4292:17) at /home/danp/DanPDev/dan-p-com-au-website/node_modules/sass/sass.dart.js:13233:20 @ ./src/components/layout.js 19:0-26 @ ./src/pages/404.js 8:0-42 12:42-48 @ ./.cache/_this_is_virtual_fs_path/$virtual/async-requires.js 16:11-18:5 @ ./.cache/app.js 17:0-52 28:0-70 30:27-40 28:0-70
1 ERROR in child compilations (Use 'stats.children: true' resp. '--stats-children' for more details) webpack compiled with 2 errors
No messages yet