menu

Gauge

Light weight cross-platform test automation

Channels
# All channels
view-forward
# General
view-forward
# Meta
view-forward
# News
view-forward
Team
Posts
Members
Info

Mimimum support version

I've got an error in Visual Code: Failed to start gauge API: Compatibility error. Incompatible version. Minimum support version 1.0.7 is higher than 1.0.6. Extension is 0.0.12, and Gauge is 1.0. 6. As I understand this is expected behaviour, but how can I resolve it ?

thumbsup
1
message-simple
6

Requesting help with gauge maven plugin being stuck with no error message

I am running gauge tests with selenium using gauge maven plugin. Gauge is stuck and doesn't throw any error message. Following is the pom profile to run gauge: <plugin> …

thumbsup
0
message-simple
1

Facing issue with gauge maven plugin stuck with no error message

I am trying to run selenium tests using gauge maven plugin. It is stuck after few WARN and a message "Reflections:169 - Reflections took 4105 ms to scan 255 urls, producing 9725 keys and 116151 values" It doesn't go ahead nor throw and error …

thumbsup
0
message-simple
1

Please ask if the gauge can be used in the following way.

First of all, thank you for making and sharing a good tool I am currently using gauge-java, gauge-gradle-plugin. There is no problem when performing a large number of tests using the above method, …

thumbsup
0
message-simple
1

Is this the right place to ask for help for Gauge issues?

I am currently having issues creating a new template project with Gauge & VS Code. I get the following error: gauge init -t Error ---------------------------------- …

thumbsup
0
message-simple
2

Taiko-accessibility plugin does not work with Gauge

I see that there is a Taiko plugin taiko-accessibility for testing accessibility. I have tried using it with Gauge and I am unable to run it successfully. The example that is provided is with the Jest framework. Any help is appreciated if the Taiko team or if the author of the…

thumbsup
0
message-simple
9

Gauge python isn't working on python3.9

Hi, i've installed python3.9 and it seems that gauge with python doesn't work. Even if i run the default gauge project, i'm receiving Step implementation not found OS: Debian GNU/Linux 10 And the output when running gauge run specs/ …

thumbsup
0
message-simple
3

Parallel execution of scenarios in a spec

In parallel execution, do scenarios in the same spec run sequentially in the order they are written in OR do they run in parallel? Basically i want to write a few specs where scenarios depend upon the previous scenarios and assume they are run in the specified order. Will they…

thumbsup
0
message-simple
1

Can we run specs in parallel when we have data driven specifications

In https://spectrum.chat/gauge/general/can-i-run-scenarios-in-parallel-or-is-it-only-specs-in-gauge~607e9132-f7b4-4d1d-bb00-0708221f90f6, it is mentioned that row will run in parallel. But we want to run specs in parallel. Is it possible? …

thumbsup
0
message-simple
6

Can we integrate Gauge appium tests with Microsoft Appcenter

I have gauge appium tests and trying to integrate with microsoft appcenter(cloud-for testing) . since appcenter uses maven-surefire plugin to execute tests, it is not identifying any tests and throwing an exception. so is there possibility where we can run specs using maven…

thumbsup
0
message-simple
8