menu

inDomus.it

community italiana di domotica personale (...tutti siamo stati incapaci all'inizio)

Channels
Team

[solved] integrazione sistema bticino living now ad homeassistant

August 26, 2019 at 5:46pm
The inDomus.it community has a new home. This thread is preserved for historical purposes. The content of this conversation may be innaccurrate or out of date. Go to new community home →

[solved] integrazione sistema bticino living now ad homeassistant

August 26, 2019 at 5:46pm (Edited 1 year ago)
ciao all'acquisto della casa ho fatto installare il sistema livin now bticino che tramite un gateway K4500C riesce a comandare tapparelle,prese e luci tramite ZigBee. il gateway è compatibile con Homekit ma ancora niente per Homeassistant. arrivo al dunque, è possibile tramite chiavetta conbee agganciare i dispositivi connessi al gateway?
Show previous messages

December 6, 2019 at 3:01pm
allora, il problema era la mia fretta e stupidità! mi ero preoccupato che il gateway si associasse all'interruttore connesso ma non avevo fatto il passaggio dall'app Home+ per associare il gateway alla wifi … era ovvio che hassio non lo vedesse! ora però ho il problema con questo passaggio. seguo le istruzioni dell'app ma non si collega alla wifi. mi da codice errore 4 impossibile raggiungere il gateway, come se la password fosse errata ma ovviamente non lo è …
  • reply
  • like
eh qui ti conviene sentire bticino o vedere nel manuale di istruzioni cosa dice..
  • reply
  • like
aggiornamento: il problema era la password. avevo quella di default del router tim fibra ed era troppo complessa (credo troppi caratteri). Una volta semplificata ha funzionato tutto. Ho poi verificato una cosa di cui sono molto contento: i pulsanti su hassio lavorano anche in local, senza rete internet. Una cosa però non funziona: l'integrazione con alexa (ovviamente senza skill). io ho integrato alexa su hassio, come da guida sul sito indomus, e fino ad ora se aggiungevo un componente in hassio poi alexa lo scopriva e gestiva. questa volta no. qualcuno c'è riuscito senza usare la skill di alexa?
  • reply
  • like

December 7, 2019 at 1:57pm
non avendo alexa non ti so aiutare :(
  • reply
  • like

January 17, 2020 at 9:49pm
resuscito il topic perchè ho notato che con l'aggiornamento di zigbee2mqtt alla versione 1.9 sembra siano compatibili gli accessori della linea living now. qualcuno che ha fatto dei test?
  • reply
  • like

January 18, 2020 at 6:56am
Controllando la documentazione sembra sia compatibile il deviatore connesso e nessun altro componente. Vedrò di fare l'esperimento ma se non vede ne il relè da presa ne il contatore consumo ... tanto vale rimanere con la semplicissima integrazione di homekit
  • reply
  • like
Veramente non si capisci se sia il deviatore o l’interruttore per presa il supportato! La foto su zigbee2mqtt è dell’interruttore presa ma la descrizione è dell’interruttore/deviatore per luci...
Edited
  • reply
  • like
Ce lo ho tutti e due, vediamo cosa succede
  • reply
  • like
Facci sapere
  • reply
  • like
potrebbe comunque essere utile collegare le prese connesse anche senza i consumi in modo da estendere la rete no?
  • reply
  • like
da quanto letto su github, la presa connessa K4531C dovrebbe essere compatibile perchè riporta lo stesso codice della presa modello Celiane che zigbee2mqtt mette nella lista dei dispositivi supportati. Tra l'altro,nella lista compatibili, viene riportato anche il comando luci K4003C che viene descritto con codice errato (K3004C) e anche l'immagine errata (presa connessa K4531C)
Edited
  • reply
  • like
infine ritengo comunque che chi abbia il gateway K4500C gli convenga esporre luci e tapparelle tramite homekit così da avere l'app legrand come riserva nel momento in cui abbia problemi con home assistant e associare solo le prese direttamente con zigbee2mqtt in modo da avere i consumi.
  • reply
  • like
secondo voi bisognerà installare il firmware coordinator 3.0 o basta la versione 1.2?
  • reply
  • like
Aggiornamento. Il sistema sembra li rilevi e li colleghi correttamente. Però devo approfondire diverse cose perché non mi sembra che i comandi via mqtt siamo del tutto funzionanti. Tra l'altro la presa viene riconosciuta anche come rilevatore dei consumi ma non sono riuscito a capire come fare a leggerli. L'auto discovery la rileva come un interruttore. Se agisco manualmente sull'interruttore BTicino l'aggiornamento dello stato non avviene su HA. Probabilmente c'è qualcosa su mqtt che non conosco, d'altronde feci pochi esperimenti con un sonoff/tasmota ma li i messaggi da interruttore a HA erano corretti e immediati. Per quanto riguarda la versione 1.2 o 3 io ho installato la 3 perché lessi che la 1.2 non supportava il protocollo ZigBee usato da BTicino
Edited
  • reply
  • like
Che chiavetta usi?
  • reply
  • like
cc2531. tra l'altro ti confermo che andando su configurazione>integrazioni>mqtt su HA i due dispositivi vengono classificati come produttore Bticino per il deviatore, modello Light switch with neutral (ma con codice errato K3004c) mentre la presa è produttore Legrand, modello Power socket with power consumption monitoring (067775). Guardando sul sito di zigbee2mqtt, nella sezione degli articoli compatibili, e andando su Legrand al 067775 ci sono le istruzioni per una integrazione manuale e non tramite mqtt discovery. Ora lo inserisco manualmente e vedrò se il controllo consumi funziona
Edited
  • reply
  • like
Super 👍 tienici aggiornati
Edited
  • reply
  • like
Riesci anche a vedere se poi i dispositivi riescono a fare da router ad altri dispositivi non della linea living now?
  • reply
  • like
Riesci anche a vedere se poi i dispositivi riescono a fare da router ad altri dispositivi non della linea living now?
no questo non saprei come fare.
  • reply
  • like
cc2531. tra l'altro ti confermo che andando su configurazione>integrazioni>mqtt su HA i due dispositivi vengono classificati come produttore Bticino per il deviatore, modello Light switch with neutral (ma con codice errato K3004c) mentre la presa è produttore Legrand, modello Power socket with power consumption monitoring (067775). Guardando sul sito di zigbee2mqtt, nella sezione degli articoli compatibili, e andando su Legrand al 067775 ci sono le istruzioni per una integrazione manuale e non tramite mqtt discovery. Ora lo inserisco manualmente e vedrò se il controllo consumi funziona
Tra i dispositivi c’è anche il relè connesso sotto il marchio legrand che dovrebbe essere lo stesso di bticino
  • reply
  • like
Dopo aver inserito manualmente come da istruzioni i parametri del dispositivo presa direi che ho risolto tutto. A differenza del deviatore questa risponde perfettamente ai comandi di HA, si attiva e disattiva perfettamente con il pulsante e legge i consumi. Non so se e quanto è affidabile la lettura ma attaccando un phon da 2200W dava un consumo di 1780. Per il deviatore invece le cose non vanno troppo bene. se si usano solo i tasti virtuali di HA tutto ok, ma come si usa il tasto fisico le cose si complicano e cominciano a non essere più coordinati. domani faccio altri esperimenti
Edited
  • reply
  • like
Le prese come le hai disconnesse dal gateway?
  • reply
  • like
Semplicemente ho tolto corrente al gateway. Poi ho tenuto premuto il tasto reset sul deviatore. Il relè da presa invece era nuovo di pacca, non lo avevo ancora installato
  • reply
  • like

January 19, 2020 at 12:05pm
Per mettere il dispositivo in modalità accoppiamento basta che la luce sia rossa?
  • reply
  • like
si. Sempre parlando del relè presa, i sensori che vanno inseriti sono in realtà 2, uno ha come unità di misura "w" ed è facile capire a cosa serve, l'altro ha come unità di misura "-". Questo sensore va aggiunto anche per il deviatore. Non ho capito che informazione restituisce e a cosa serve. Per esempio in questo momento che sto ricaricando il cellulare uno segna "7 w", l'altro "28 -". Qualcuno sa cosa significa?
Edited
  • reply
  • like
Show more messages