menu
announcement

Spectrum is now read-only. Learn more about the decision in our official announcement.

infrastructure

Infrastructure-Components let you configure your React App Infrastructure easily

Channels
Team

[email protected] node version issue - is it known?

February 16, 2020 at 7:35pm

[email protected] node version issue - is it known?

February 16, 2020 at 7:35pm (Edited 2 years ago)
Hello, I am new with IC. Am triggered by the recent article of "Data-Driven React with Apollo, DynamoDB, and Infrastructure-Components. Wanted to give it a try. My fav is yarn, not npm. But my installation fails with this error:
error [email protected]: The engine "node" is incompatible with this module. Expected version "^6.3.0". Got "12.13.0"
Is it a known issue?
The error happens when installing the insfrastructure-scripts.
It also fails with npm on post-install script. Here is the relevant part of the error at the end of the run:
> ./scripts/icscriptsinstall.js
'.' is not recognized as an internal or external command,
operable program or batch file.
npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^6.3.0","npm":"^3.10.3"} (current: {"node":"12.13.0","npm":"6.13.6"})
npm WARN notsup Not compatible with your version of node/npm: [email protected]
npm WARN [email protected] No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\@serverless\cli\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] postinstall: `./scripts/icscriptsinstall.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Or is the issue that I am on a Windows 10 machine and not on a Mac OS X?

February 16, 2020 at 8:41pm
Hi, this issue is caused by the dependency. The workaround with yarn is: yarn install --ignore-engines
I plan to replace the dependency in future

February 19, 2020 at 7:18pm
Hi Frank, thank you for your advice. I will give your article another go now. :)

February 20, 2020 at 4:52am
Alas. Now, the error is different. It seems to occur at the moment that the icscriptinstall.js is being called:
error C:\src\vvn-cso-dyn-rct-mst\node_modules\infrastructure-scripts: Command failed.
Exit code: 1
Command: .\scripts\icscriptsinstall.js
Arguments:
Edited

March 8, 2020 at 5:24pm
Hi Andre, this seems to be a Windows issue. Unfortunately, it is not so easy to fix right now. Do you have a Mac or Linux system?
Not at the moment I am afraid. But thanks for telling me.
I'll let you know when I have an update on this