menu

JS Everywhere

A community for the JavaScript Everywhere book by Adam Scott, published by O'Reilly.

Channels
Team

Chp 21: Error "Something went wrong. 33.0.0 is not a valid SDK version"

July 6, 2020 at 1:44am

Chp 21: Error "Something went wrong. 33.0.0 is not a valid SDK version"

July 6, 2020 at 1:44am
After I follow the example given in the book and run the app in the Android emulator, it give the above error message. I try on my Android device (OnePlus6) and it has the same error. (I use Mac)

July 6, 2020 at 1:44am
The Expo Client Version on my Android device is 2.16.1 and it saids it support Expo SDK 38
  • reply
  • like
Oh, sorry for the trouble, I just find that in app.json there is a setting that I can change the sdk version ("sdkVersion": "35.0.0",). After change to 35, it is working now.
  • reply
  • like

July 6, 2020 at 11:33am
Glad to hear that you got it sorted!
like-fill
1
  • reply
  • like