menu
Channels
Chat
view-forward
# All channels
view-forward
# General
view-forward
# Announcements
view-forward
# Bugs
view-forward
# Features
view-forward
# Help
view-forward
Team
Posts
Members
Info

After 'Export current environment' rules disappear

1. export current environment. 2. import exported environment again. 3. rules are gone. (disappear) …

thumbsup
0
message-simple
2

Mockoon constantly losing all previously created environments

For some reason my mockoon app sometimes losing all created environments. Not sure why. This already happened 3 times during month. I am trying keep json backup up to time to be safe, but this behavior is weird. Does anyone experiencing something similar?

thumbsup
0
message-simple
39

HTTPS is failing.

I've set it up following the (very terse) tutorial. There doesn't seem to be much opportunity to do it wrong but I'm still getting 502s returned from it.

thumbsup
0
message-simple
15

Internal error on bad parsing of a request

Well, seems that if we have a request that contains into content type header 'application/json', mockoon tries to parse it as json. If this is not a valid json an error occurs (we can see it logged to the log file) and swallows the request, which means that we can not see it…

thumbsup
0
message-simple
13

Mockoon did not save environment

Hey I restarted my laptop (Windows) for a system update and when I got it back on I noticed no environments on Mockoon, is this just a bug? Or did I forget to hit save somewhere? I dont remember having this problem on Linux. Is there a place I should look for a potential copy of…

thumbsup
0
message-simple
5

oneOf and someOf not working

Hey there! I'm trying to use the dynamic templating so i get variable returns from my mock API, but it seems like the functions "oneOf" and "someOf" aren't working. I could be implementing them incorrectly, but I'm using the same syntax and such from the example on the mockoon…

thumbsup
0
message-simple
12

404 Page not adding custom headers

I ran into this issue earlier tonight and I'm not sure whether or not it is intentional. For some debugging reasons I have the CORS headers added to my request, but when I try to get a bad route eg /foobar, for a resource that doesn't exist, the response does not include the…

thumbsup
0
message-simple
2

404's on the website

eg: https://mockoon.com/tutorials/serve-mock-api-tls https://mockoon.com/features/tutorial/automatic-handling-preflight-requests

thumbsup
0
message-simple
6