menu

Mockoon

Mockoon's official community. Get help, discuss new features.

Channels
Chat
view-forward
# All channels
view-forward
# General
view-forward
# Announcements
view-forward
# Bugs
view-forward
# Features
view-forward
# Help
view-forward
Team
Show previous messages

November 6, 2019 at 8:43am
is it also possible to check for missing attributes? :-)
  • reply
  • like
Not yet. But mockoon's aim is to stay simple to use. So the rule system is voluntarily basic and simple to use.
  • reply
  • like
Anyway if it's needed it will probably be added at one point 🙂
  • reply
  • like

November 6, 2019 at 8:16pm
Hello. I have to use the same {{guid}} in the same template several times. Is it possible in the current version?
Edited
  • reply
  • like

November 7, 2019 at 8:13pm
Hello not yet. There is an issue opened for this use case. I think it would be solved with some sort of variables that would support templating. https://github.com/mockoon/mockoon/issues/158
  • reply
  • like
This will be very welcome. Thanks
  • reply
  • like

November 10, 2019 at 10:42am
Help... I've restarted my laptop and now my fully created environment is gone? :-(
  • reply
  • like
It shouldn't. Environments are stored in user data folders depending on the operating system. Which OS are you using?
Edited
  • reply
  • like
windows
  • reply
  • like
have you updated Mockoon, or just a restart?
  • reply
  • like
I never encountered such problem
  • reply
  • like
just restarted laptop
  • reply
  • like
can you check that environments.json file is in c:/.../Users/xxx/AppData/Roaming/Mockoon/storage ?
  • reply
  • like
just did and it has gotten replaced with the new calls i'm creating :-(
  • reply
  • like
seems that files have been wiped or something
  • reply
  • like
I don't see anything that could overwrite completely the settings/environments
  • reply
  • like
weird :-(
  • reply
  • like
yes :(
  • reply
  • like
I'm recreating them
  • reply
  • like
I'll do a manual export when ready just to be sure
  • reply
  • like
if you reproduce this bug somehow and have an idea how it happened please let me know
  • reply
  • like
it should suffice if I copied the environment.json i assume?
  • reply
  • like
will do
  • reply
  • like
yeah normally
  • reply
  • like
it's a very basic json file
  • reply
  • like
Show more messages