menu
announcement

Spectrum is now read-only. Learn more about the decision in our official announcement.

NodeGui

A library for building cross-platform native desktop applications with Node.js and CSS.

Channels
Team

Error on npm start arm64

March 29, 2021 at 3:12am

Error on npm start arm64

March 29, 2021 at 3:12am
I have tried building qode for arm64 by cloning the repo and building using the arm64 version of qt. When running npm install and replacing the /qode with my custom build, I am getting this error on npm start:
sh: qode: command not found
where do I set the qode path in my build for the qode command to run?

April 8, 2021 at 12:34am
I found that I did not include my version of qode in the path.
When running qode through npm I am hitting the issue:
Runtime error: “must construct a QApplication before a QWidget”
Does anyone what is the cause is for this issue?

April 8, 2021 at 2:38pm
I was able to run the starter example on an arm64 system (Raspberry Pi 3B+).
You will need to download qode from github and have a compatible Qt version that is able to run on arm64 to replace the one npm installs. A few changes have to be made depending on your system to get the builds to work.
Edited