menu

Scrimba

The Scrimba community has now moved to Discord. Come in and chat with us today! http://bit.ly/scrimba-discord

Channels
Team

Issues with the browser window during React course

October 16, 2019 at 5:54am

Issues with the browser window during React course

October 16, 2019 at 5:54am
Hi, everyone after a few days into the course I've been having an issue with the browser window, which keeps displaying'Bad Request'. In order to continue the course, I have to work on my local environment. Anyone experiencing this issue?

October 17, 2019 at 2:46am
Hey, Michele!
Is this problem only within the React course? If so is it happening to all the casts in the course? I have tested the code and was been able to run it successfully on my end without any errors.
Are you able to run the code successfully on another browser by any chance?
  • reply
  • like

October 18, 2019 at 5:34am
I get the same error with the other courses as well. I've tried it on Firefox and run into the same issue. I'm used to work in my local environment with React, it's just a bit annoying to create a new React app for every single exercise sometimes :)
Edited
  • reply
  • like

October 18, 2019 at 12:20pm
I get the same error with the other courses as well. I've tried it on Firefox and run into the same issue. I'm used to work in my local environment with React, it's just a bit annoying to create a new React app for every single exercise sometimes :)
Okay, we'll have a look into it 🙂
  • reply
  • like

October 20, 2019 at 11:13am
I have the exact same problem now; after working fine for ~30 "episodes" of React it suddenly started to happen. The only thing that happened between working and not working was that I was away from the computer for a long time after I started modifying the code the tutor had written.
  • reply
  • like

October 21, 2019 at 5:09am
I have tested on the latest Firefox - 69.0.3 (64-bit) and Chromium - 77.0.3865.120 (64-bit) and wasn't able to replicate the issue. I tried it on some previous versions and the issue still didn't arise.
Could you see if a hard refresh changes anything?
  • reply
  • like

October 21, 2019 at 6:34pm
I've tried that, but still nothing. Oh well I have finished the React course by now and did half of the projects in my local environment, I will keep doing the same if I take other courses. Thank you for the great free material you put in!!!
  • reply
  • like
I'm getting the same issue
  • reply
  • like

October 22, 2019 at 1:25am
Okay, we'll work on the issue. Will keep you guys posted!
  • reply
  • like

October 22, 2019 at 8:21am
Hi! I am having the same problem with browser window. Can not see half of the code because of it. Closing buttons disappeared. React course, React Props
like-fill
1
  • reply
  • like
Hi, a quick update to say that we are looking into this. It seems to be a few issues that look the same. We are trying to untangle them and fix them separately.
  • reply
  • like
That issue is because the cast was recorded with a very big mini-browser. You can reposition it yourself with your cursor actually. Then you'll see the buttons on the mini-browser as well.
  • reply
  • like

October 22, 2019 at 7:38pm
Regarding the issue where some people are getting a blank/white browser window when refreshing. This was caused by the server that imported dependencies reaching some limits. We have changed how this is done today and hopefully you will not have this issue anymore.We have two other open issues with the browser that we will fix the next days.
  • reply
  • like
Please let us know if you see the issue again
  • reply
  • like

January 2, 2020 at 6:29am
Hey! I'm facing this issue with browser window displaying 'Bad Request' whenever I click on "run code/reload" button. Could anyone please help...
  • reply
  • like
Hi , sorry about this. Do you have multiple tabs open when it happens?
  • reply
  • like
Hey! I'm facing this issue with browser window displaying 'Bad Request' whenever I click on "run code/reload" button. Could anyone please help...
If your playground is public, please share the link.
  • reply
  • like

January 16, 2020 at 7:14am
I was having some issues with the mini browser not loading properly as well in the past but then I updated chrome and It has been working great ever since.
like-fill
1
  • reply
  • like