menu

Scrimba

The Scrimba community has now moved to Discord. Come in and chat with us today! http://bit.ly/scrimba-discord

Channels
Team

[Resolved] Error: Unknown require: bootstrap/less/bootstrap.less

August 5, 2019 at 9:38pm

[Resolved] Error: Unknown require: bootstrap/less/bootstrap.less

August 5, 2019 at 9:38pm (Edited 12 months ago by @rokublac)
Learning React. Added React-Bootstrap to my project (Since we are a bootstrap shop) I am learning React and having problems loading the bootstrap css. Documentation states: .... import the less Bootstrap entry point in App.js with the line import 'bootstrap/less/bootstrap.less'. When doing this I get the above error. Thank you, Joe

August 7, 2019 at 3:14am
Hi, Joe
Could you please link me to the Scrimba playground of yours? If it's private, feel free to send it through via direct message and I'll have a look at it to see what's up.
Thanks!
  • reply
  • like

August 7, 2019 at 5:12pm
Since my original question i have proceeded to modify and make several changes to get something basic to work. Not getting the same error but I am having troubles getting the bootstrap-min.css files to work. I im'd you a link
Edited
  • reply
  • like

August 8, 2019 at 1:50am
Okay, thanks. Will have a look at it now.
  • reply
  • like

August 8, 2019 at 12:33pm
Hi, Joe
Unfortunately at this time, Scrimba does not support importing CSS into your JS files in React. I'll put this on our list and create an issue for you on our GitHub page.
  • reply
  • like
An issue has now been created regarding this situation. It can be found here
  • reply
  • like

December 18, 2019 at 3:16pm
Do you have a link to a playground showing the usage? I can take a closer look but would love a reproducer. Thanks 🙏🏾
Edited
  • reply
  • like