menu

Sketch

Over one million designers use Sketch to transform their ideas into incredible products, every day.

Channels
Team

Group pixel fiting

February 9, 2019 at 5:24pm

Group pixel fiting

February 9, 2019 at 5:24pm
Hi, i have a problem. I have some elements on my artboard. When i select them i se total size of 40x40px. When i click group then i see a size of 40x41px. Is this a known bug?

February 9, 2019 at 6:25pm
Are there any hidden elements in the group?
  • reply
  • like
No. It's a totally simple composition. Top is elements only selected (40x40px) and bottom if i add them into a group (40x41px). The same elements are ok in Figma.
  • reply
  • like

February 10, 2019 at 3:51pm
have you ungrouped and regrouped? Sometimes the group can be off.
like-fill
3
  • reply
  • like
Sometimes, it may also be a shadow that is either applied to an individual element or to the group as a whole.
  • reply
  • like
Try pressing Enter with the shape selected to enter shape editing but don't change anything. If that doesn't work, check every vector point and see their x and y are whole numbers.
  • reply
  • like
Done all of this, doesn't help. No shadows, simple shape with color. Looks like i have to go back to Figma for work.
  • reply
  • like
Done all of this, doesn't help. No shadows, simple shape with color. Looks like i have to go back to Figma for work.
If you send the file over to me I can check on it and see if im seeing the issue as well. Maybe thatll help narrow it down
  • reply
  • like

February 11, 2019 at 5:55am
Try ungroup, select every layers and then you can regroup again. Sometimes, just ungroup and regroup again.
  • reply
  • like
that's an annoying bug since ever in Sketch … sometimes the ungroup/group helps ... sometimes it's when your element is placed on subpixels ... make sure it's on even pixels ... Sometimes it happens when you delete something in a group - the group size doesn't refresh, so you have to move something inside a group - then move it back again and the Group size refreshes ... hope it will be fixed someday.
  • reply
  • like

February 13, 2019 at 4:12pm
I keep having this bug (for years now) and it's so annoying. Sometimes ungrouping works, sometimes checking the shapes works, but other times it's just what you have to deal with. I really wish they could fix it...
  • reply
  • like

February 17, 2020 at 7:54pm
do you have Anima installed ? I had this same issue and it was caused by Anima, worth checking.
  • reply
  • like