155: Naming conventions for RxJava ObservablesMarch 12, 2019 at 3:24pm
The Android community has come to use Rx pretty heavily but surprisingly there hasn't been any one convention that's won, when it comes to how we name our functions that return Observables.
userUpdates() ? In this mini-episode dutifully does the yak-shaving for you and discusses what some options are and what the community has been gravitating towards.
// option 1fun getUser(): Single<User>// yuck// option 2fun user(): Observable<User>// but what does this mean?// option 3fun user(): Single<User>fun userUpdates(): Observable<User>// orfun userStream(): Observable<User>// this is looking good// option 4 (upday style)fun userOnce(): Single<User>fun userStream(): Observable<User>fun userOnceAndStream(): Observable<User>
Stay tuned for a future episode, where we discuss more details and more complicated cases to handle (like emitting a list of user, policies for fetching the first user as quickly as possible etc.).