menu
Channels
Team

Installing Theia

June 4, 2020 at 3:07pm

Installing Theia

June 4, 2020 at 3:07pm
I installed Theia following this tutorial in my local Kubernetes cluster (https://www.digitalocean.com/community/tutorials/how-to-set-up-the-eclipse-theia-cloud-ide-platform-on-digitalocean-kubernetes). I can see the pod is up and running. However, when I access it in my browser (localhost:80), it keeps loading forever. I checked "Network" tab in browser and it is calling this service repeatedly "ws://localhost/services". What wrong I could possibly be doing ?

June 4, 2020 at 3:15pm
please note that we are not the authors of the tutorial, if you are having issues with the tutorial itself maybe it's worthwhile to ask the question directly in the comment section https://www.digitalocean.com/community/tutorials/how-to-set-up-the-eclipse-theia-cloud-ide-platform-on-digitalocean-kubernetes. I haven't done the tutorial myself so I'm not sure how much help I could be at this moment.
  • reply
  • like
is there any other tutorial/guide I can follow to install it ?
  • reply
  • like
is there any other tutorial/guide I can follow to install it ?
are you looking to install on kubernetes or in general?
  • reply
  • like
are you looking to install on kubernetes or in general?
Happy to try both
  • reply
  • like
as far as I am aware we don't have any official documentation on running within Kubernetes. We do have the following getting-started options which reference different ways to try out the framework (including example docker images).
If you are looking into building your own application, you can reference the composing applications section of our website.
I hope this will help you get started in trying out the framework :)
like-fill
1
  • reply
  • like
private
This channel has been archived