Join the conversation

Sign in to join this conversation, and others like it, in the communities you care about.

Sketch

The Sketch community on Spectrum. Sketch is the ultimate tool for designing user interfaces, websites, and icons.

Sketch / Help

InVision's Craft plugin not syncing layout settings properly

InVision's Craft plugin not syncing layout settings properly

Sketch/Help · August 24, 2017 at 11:27am

InVision's Craft plugin not syncing layout settings properly

Sketch / Help · August 24, 2017 at 11:27am (Edited 1 year ago)
I have this layout settings in my Sketch file:  
When I sync the file via the Craft Sync plugin I get this on the Inspect page on InVision:  
The columns are displaced to the right, outside the actual document boundaries like this:  
Has anyone ever faced this issue? Any clues on what's happening?
Thanks so much for the support.

August 24, 2017 at 2:33pm
uh oh thats no good. I haven't seen that happen, but then again I rarely use Inspect. I would try submitting a bug report with these screenshots.
  • reply
  • like
I know this is the lame answer but you could try re-installing craft to see if that fixes anything
  • reply
  • like
Thank you Josh! I'll try re-installing Craft and hope it works. Thanks so much for your answers!
like-fill
1
  • reply
  • like

August 30, 2017 at 11:47pm
You might also center the layout and click it on and off a couple times before syncing again. I'm not sure if that will work, but I know that sometimes when I use layout it doesn't position correctly in Sketch and I have to center it or reset it before it works correctly. Just an idea.
  • reply
  • like

November 15, 2017 at 10:52am

Hi, I had the same issue recently. Reinstalling Craft solved it for me.

  • reply
  • like

November 7, 2018 at 7:02pm

I have the same issue and reinstalling Craft did not work for me. I also tried the other suggestion of centering, left, center and then center again to get it to export correctly, but it never works

  • reply
  • like

November 8, 2018 at 2:43pm

Hey Daniel, this has been an ongoing problem with InVision Inspect, and for complex pages still hasn't been resolved. We eventually had to move to Zeplin because it became problematic for devs.

  • reply
  • like
Your message here...

*bold*_italic_`code````codeblock```