menu

ZEIT

Our mission is to make cloud computing as easy and accessible as mobile computing. You can find our Next.js community here.

Channels
Team

v1 deployment going very strange - "installing alpine and MUCH more"

October 1, 2019 at 4:46pm
The ZEIT community has a new home. This thread is preserved for historical purposes. The content of this conversation may be innaccurrate or out of date. Go to new community home →

v1 deployment going very strange - "installing alpine and MUCH more"

October 1, 2019 at 4:46pm
Full log - it's big and all of the deploys I've done, I've never seen this (this particular repo was working the last time I was deployed - yesterday):
> UPDATE AVAILABLE Run `yarn global add [email protected]` to install Now CLI 16.3.0
> WARN! You are using an old version of the Now Platform. More: https://zeit.co/docs/v2/advanced/platform/changes-in-now-2-0
> Deploying ~/Sites/ffconf under rem
> Using project ffconf
> Synced 1 file (1.64KB) [609ms]
> Using Node.js 10.7.0 (requested: `10`)
> https://ffconf-qirabiakvj.now.sh [v1] [in clipboard] (bru1) [2s]
> Installing build runtime...
> [now-builder-debug] yarn add @now/[email protected]
> [now-builder-debug] [2/4] Fetching packages...
> [now-builder-debug] [1/4] Resolving packages...
> [now-builder-debug] [2/4] Fetching packages...
> [now-builder-debug] [3/4] Linking dependencies...
> [now-builder-debug] ├─ [email protected]
> [now-builder-debug] ├─ [email protected]
> [now-builder-debug] ├─ [email protected]
> [now-builder-debug] ├─ [email protected]
> [now-builder-debug] ├─ [email protected]
> [now-builder-debug] ├─ [email protected]
> [now-builder-debug] Running builder.exports.build...
> INFO[0000] Resolved base name node:10.7.0-alpine to node:10.7.0-alpine
> INFO[0001] Error while retrieving image from cache: getting file info: stat /cache/sha256:9787e45382cb61f65068dbb1ef58337888f55f51f4dfc9455643a1db44da71a4: no such file or directory
> INFO[0002] Built cross stage deps: map[]
> INFO[0003] Executing 0 build triggers
> INFO[0101] Taking snapshot of full filesystem...
> INFO[0105] WORKDIR /home/nowuser
> fetch http://dl-cdn.alpinelinux.org/alpine/v3.8/community/x86_64/APKINDEX.tar.gz
> (12/33) Installing musl-dev (1.1.19-r11)
> (25/33) Installing python2 (2.7.15-r2)
> INFO[0109] cmd: /bin/sh
> fetch https://dl-3.alpinelinux.org/alpine/edge/testing/x86_64/APKINDEX.tar.gz
> fetch http://dl-cdn.alpinelinux.org/alpine/v3.8/main/x86_64/APKINDEX.tar.gz
> (3/62) Upgrading libffi (3.2.1-r4 -> 3.2.1-r6)
> (5/62) Installing file (5.37-r0)
> (7/62) Installing build-base (0.5-r1)
> (9/62) Installing fftw-long-double-libs (3.3.8-r0)
> (11/62) Installing fftw-dev (3.3.8-r0)
> (13/62) Installing python3 (3.6.8-r0)
> (15/62) Installing gettext-asprintf (0.20.1-r1)
> (17/62) Installing libunistring (0.9.10-r0)
> (19/62) Installing libxml2 (2.9.9-r2)
> (21/62) Installing gettext-dev (0.20.1-r1)
> (23/62) Installing libxml2-utils (2.9.9-r2)
> (25/62) Installing libgcrypt (1.8.5-r0)
> (27/62) Installing docbook-xml (4.5-r6)
> Executing docbook-xsl-1.79.1-r1.post-install
> (31/62) Installing pcre (8.43-r0)
> (33/62) Installing linux-headers (4.19.36-r0)
> (35/62) Installing libpcre16 (8.43-r0)
> (37/62) Installing libpcrecpp (8.43-r0)
> (39/62) Installing libuuid (2.34-r0)
> (41/62) Installing libsmartcols (2.34-r0)
> (43/62) Installing zlib-dev (1.2.11-r3)
> (45/62) Installing libjpeg-turbo (2.0.3-r0)
> (47/62) Installing tiff (4.0.10-r1)
> (49/62) Installing tiff-dev (4.0.10-r1)
> (51/62) Installing lcms2-dev (2.9-r1)
> (53/62) Installing libexif-dev (0.6.21-r3)
> (55/62) Installing libpng-dev (1.6.37-r1)
> (57/62) Installing libwebp-dev (1.0.3-r0)
> (59/62) Installing orc-dev (0.4.30-r0)
> (61/62) Installing vips (8.8.2-r0)
> yarn install v1.7.0
> warning @11ty/eleventy > dependency-tree > precinct > detective-postcss > postcss-values-parser > [email protected]: I wrote this module a very long time ago; you should use something else.
> [3/5] Fetching packages...
> info [email protected]: The platform "linux" is incompatible with this module.
> worker exited with code 20 and signal null
> Error! Build failed
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] postbuild: `now --token=$NOW_TOKEN && now alias --token $NOW_TOKEN`
npm ERR! Exit status 1

October 1, 2019 at 5:24pm
Hi Are you saying that your builds are failing for the same project that you deployed successfully yesterday? Can you provide the URL for a failed build so we can dive deeper?
  • reply
  • like
Also, would you be able to give us access to the repo? Feel free to email details to [email protected] where you an attach a .zip of your project.
  • reply
  • like
Note that these URLs are netlify, but cross down and search for now and you'll find where the deploys to Zeit are triggered.
  • reply
  • like
Getting the same errors locally (which I pasted in the original post).
The repo to the project is here: http://github.com/leftlogic/ffconf/
  • reply
  • like
…any ideas? Something's changed on the v1 platform, and maybe it happened a while ago and I missed it, but simple deployments with 2 dependencies going up to v1 are taking about 3 minutes and producing similar output (though passing) - but installing the full OS deps.
  • reply
  • like
private
This channel has been archived